const regex = /((?:(?:public|private|protected|static|final|abstract|synchronized|volatile)\s+)*)\s*(\w+)\s*(\w+)\(.*?\)\s*({(?:{[^{}]*(?:{[^{}]*}|.)*?[^{}]*}|.)*?})/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?:public|private|protected|static|final|abstract|synchronized|volatile)\\s+)*)\\s*(\\w+)\\s*(\\w+)\\(.*?\\)\\s*({(?:{[^{}]*(?:{[^{}]*}|.)*?[^{}]*}|.)*?})', 'sg')
const str = `public static FieldsConfig getFieldsConfig(){
if(xxx) {
sssss;
}
else {
xcvxcv;
if(yyy) {
Doit();
}
}
return;
}
static void Next() {};
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}