$re = '/((?:(?:public|private|protected|static|final|abstract|synchronized|volatile)\s+)*)\s*(\w+)\s*(\w+)\(.*?\)\s*({(?:{[^{}]*(?:{[^{}]*}|.)*?[^{}]*}|.)*?})/s';
$str = 'public static FieldsConfig getFieldsConfig(){
if(xxx) {
sssss;
}
else {
xcvxcv;
if(yyy) {
Doit();
}
}
return;
}
static void Next() {};
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);