package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)>[\w\s]+<`)
var str = `<p><span style="color: rgb(166, 25, 133);"> tE</span>XT HJKHK jhjklj<span style="color: rgb(58, 181, 195);">n bсbrjmhnjmhnj</span></p><p><br></p><p><span style="color: rgb(58, 181, 195);">bnjksahdjsa </span><b style="color: rgb(58, 181, 195);">sdasadsa</b><b style="color: rgb(95, 17, 77);"> sddsdwsd </b></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}