import Foundation
let pattern = #">[\w\s]+<"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<p><span style="color: rgb(166, 25, 133);"> tE</span>XT HJKHK jhjklj<span style="color: rgb(58, 181, 195);">n bсbrjmhnjmhnj</span></p><p><br></p><p><span style="color: rgb(58, 181, 195);">bnjksahdjsa </span><b style="color: rgb(58, 181, 195);">sdasadsa</b><b style="color: rgb(95, 17, 77);"> sddsdwsd </b></p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)