# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r">[\w\s]+<"
test_str = "<p><span style=\"color: rgb(166, 25, 133);\"> tE</span>XT HJKHK jhjklj<span style=\"color: rgb(58, 181, 195);\">n bсbrjmhnjmhnj</span></p><p><br></p><p><span style=\"color: rgb(58, 181, 195);\">bnjksahdjsa </span><b style=\"color: rgb(58, 181, 195);\">sdasadsa</b><b style=\"color: rgb(95, 17, 77);\"> sddsdwsd </b></p>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.