const regex = />[\w\s]+</gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>[\\w\\s]+<', 'gm')
const str = `<p><span style="color: rgb(166, 25, 133);"> tE</span>XT HJKHK jhjklj<span style="color: rgb(58, 181, 195);">n bсbrjmhnjmhnj</span></p><p><br></p><p><span style="color: rgb(58, 181, 195);">bnjksahdjsa </span><b style="color: rgb(58, 181, 195);">sdasadsa</b><b style="color: rgb(95, 17, 77);"> sddsdwsd </b></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}