using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+)h)?((\d+)m)?((\d+)s)";
string input = @"0s
12s
1m15s
15m0s
1h0m5s
1h15m17s";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}