const regex = /((\d+)h)?((\d+)m)?((\d+)s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d+)h)?((\\d+)m)?((\\d+)s)', 'g')
const str = `0s
12s
1m15s
15m0s
1h0m5s
1h15m17s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}