$re = '/((\d+)h)?((\d+)m)?((\d+)s)/';
$str = '0s
12s
1m15s
15m0s
1h0m5s
1h15m17s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);