import Foundation
let pattern = #"((\d+)h)?((\d+)m)?((\d+)s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0s
12s
1m15s
15m0s
1h0m5s
1h15m17s
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)