package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d+)h)?((\d+)m)?((\d+)s)`)
var str = `0s
12s
1m15s
15m0s
1h0m5s
1h15m17s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}