package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:https?:\/\/)?(?:www\.)?youtu(.be|be\.com)\/watch\?.*?v=([^&#]+).*$`)
var str = `http://youtube.com/watch?source=youtu.be&v=abcdefghijk&list=foo-bar#t=20s`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}