import Foundation
let pattern = ##"^(?:https?:\/\/)?(?:www\.)?youtu(.be|be\.com)\/watch\?.*?v=([^&#]+).*$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"http://youtube.com/watch?source=youtu.be&v=abcdefghijk&list=foo-bar#t=20s"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}