const regex = /^(?:https?:\/\/)?(?:www\.)?youtu(.be|be\.com)\/watch\?.*?v=([^&#]+).*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:www\\.)?youtu(.be|be\\.com)\\\/watch\\?.*?v=([^&#]+).*$', '')
const str = `http://youtube.com/watch?source=youtu.be&v=abcdefghijk&list=foo-bar#t=20s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}