$re = '/^(?:https?:\/\/)?(?:www\.)?youtu(.be|be\.com)\/watch\?.*?v=([^&#]+).*$/';
$str = 'http://youtube.com/watch?source=youtu.be&v=abcdefghijk&list=foo-bar#t=20s';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);