re = /^(?:https?:\/\/)?(?:www\.)?youtu(.be|be\.com)\/watch\?.*?v=([^&#]+).*$/
str = 'http://youtube.com/watch?source=youtu.be&v=abcdefghijk&list=foo-bar#t=20s'
# Print the match result
str.match(re) do |match|
puts match.to_s
end