using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?:https?|ftp):\/{2})(?:(?:[0-9a-z_@-]+\.)+(?:[0-9a-z]){2,4})?(?:(?:\/(?:[~0-9a-z\#\+\%\@\.\/_-]+))?\/)*(?=\s|\""))(\/)?(index\.html?)?";
string substitution = @"\1/index.html";
string input = @"there is some text with <a href="" http://www.Something.com/ ""> but without index.html; then there is another one that is <a href = ""https://www.other.com/more/stuff/index.html""> which should be unaltered.
Finally does it work for href = ""http://www.com/stuff/""
http://www.index.com/
http://ex.com/a/b/""
http://www.example.com add /index.html
http://www.example.com/something do nothing
http://www.example.com/something/ add /index.html
http://www.example.com/something/index.html do nothing
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}