import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:https?|ftp):\\/{2})(?:(?:[0-9a-z_@-]+\\.)+(?:[0-9a-z]){2,4})?(?:(?:\\/(?:[~0-9a-z\\#\\+\\%\\@\\.\\/_-]+))?\\/)*(?=\\s|\\\"))(\\/)?(index\\.html?)?";
final String string = "there is some text with <a href=\" http://www.Something.com/ \"> but without index.html; then there is another one that is <a href = \"https://www.other.com/more/stuff/index.html\"> which should be unaltered.\n"
+ "Finally does it work for href = \"http://www.com/stuff/\"\n"
+ "http://www.index.com/\n"
+ "http://ex.com/a/b/\"\n\n"
+ "http://www.example.com add /index.html\n"
+ "http://www.example.com/something do nothing\n"
+ "http://www.example.com/something/ add /index.html \n"
+ "http://www.example.com/something/index.html do nothing\n";
final String subst = "\\1/index.html";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}