const regex = /((?:(?:https?|ftp):\/{2})(?:(?:[0-9a-z_@-]+\.)+(?:[0-9a-z]){2,4})?(?:(?:\/(?:[~0-9a-z\#\+\%\@\.\/_-]+))?\/)*(?=\s|\"))(\/)?(index\.html?)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?:https?|ftp):\\\/{2})(?:(?:[0-9a-z_@-]+\\.)+(?:[0-9a-z]){2,4})?(?:(?:\\\/(?:[~0-9a-z\\#\\+\\%\\@\\.\\\/_-]+))?\\\/)*(?=\\s|\\"))(\\\/)?(index\\.html?)?', 'gi')
const str = `there is some text with <a href=" http://www.Something.com/ "> but without index.html; then there is another one that is <a href = "https://www.other.com/more/stuff/index.html"> which should be unaltered.
Finally does it work for href = "http://www.com/stuff/"
http://www.index.com/
http://ex.com/a/b/"
http://www.example.com add /index.html
http://www.example.com/something do nothing
http://www.example.com/something/ add /index.html
http://www.example.com/something/index.html do nothing
`;
const subst = `\1/index.html`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);