#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^b[0-9]{4}\K|[^a-z_]"
Local $sString = "b7001_cp---_parc1323546_venc.,?><_ fluxo"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)