use strict;
my $str = 'b7001_cp---_parc1323546_venc.,?><_ fluxo';
my $regex = qr/^b[0-9]{4}\K|[^a-z_]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";