using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^b[0-9]{4}\K|[^a-z_]";
string substitution = @"";
string input = @"b7001_cp---_parc1323546_venc.,?><_ fluxo";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}