$re = '/^b[0-9]{4}\K|[^a-z_]/m';
$str = 'b7001_cp---_parc1323546_venc.,?><_ fluxo';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;