const regex = /^b[0-9]{4}\K|[^a-z_]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^b[0-9]{4}\\K|[^a-z_]', 'gm')
const str = `b7001_cp---_parc1323546_venc.,?><_ fluxo`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);