using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<header_all>
(?<header_content>.+) # Header content
[ \t]*
(?<!\\) # Making sure it is not escaped
\{
[[:blank:]\h]* # Possibly with some spaces
(?<header_attr>.+?) # and attributes instead braces
[[:blank:]\h]*
\}
[ \t]* # Possibly followed by spaces or tabs
\n # With then a new line
(?<!\\) # Making sure this is not escaped
(?<header_type>[\=|\-]+) # Multiple = or -
[ \t]* # Possibly followed by spaces or tabs
\n # Terminated by a new line
)";
string input = @"Header {#id1}
======
Header { #id2}
------
Header {.cl}
======
Header { .cl}
------
Header {.cl.class}
======
Header { .cl .class}
------
Header {#id5.cl.class}
======
Header { #id6 .cl .class}
------
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}