$re = '/(?<header_all>
(?<header_content>.+) # Header content
[ \t]*
(?<!\\\\) # Making sure it is not escaped
\{
[[:blank:]\h]* # Possibly with some spaces
(?<header_attr>.+?) # and attributes instead braces
[[:blank:]\h]*
\}
[ \t]* # Possibly followed by spaces or tabs
\n # With then a new line
(?<!\\\\) # Making sure this is not escaped
(?<header_type>[\=|\-]+) # Multiple = or -
[ \t]* # Possibly followed by spaces or tabs
\n # Terminated by a new line
)/mx';
$str = 'Header {#id1}
======
Header { #id2}
------
Header {.cl}
======
Header { .cl}
------
Header {.cl.class}
======
Header { .cl .class}
------
Header {#id5.cl.class}
======
Header { #id6 .cl .class}
------
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);