package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<header_all>
(?<header_content>.+) # Header content
[ \t]*
(?<!\\) # Making sure it is not escaped
\{
[[:blank:]\h]* # Possibly with some spaces
(?<header_attr>.+?) # and attributes instead braces
[[:blank:]\h]*
\}
[ \t]* # Possibly followed by spaces or tabs
\n # With then a new line
(?<!\\) # Making sure this is not escaped
(?<header_type>[\=|\-]+) # Multiple = or -
[ \t]* # Possibly followed by spaces or tabs
\n # Terminated by a new line
)`)
var str = `Header {#id1}
======
Header { #id2}
------
Header {.cl}
======
Header { .cl}
------
Header {.cl.class}
======
Header { .cl .class}
------
Header {#id5.cl.class}
======
Header { #id6 .cl .class}
------
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}