import Foundation
let pattern = ##"""
(?<header_all>
(?<header_content>.+) # Header content
[ \t]*
(?<!\\) # Making sure it is not escaped
\{
[[:blank:]\h]* # Possibly with some spaces
(?<header_attr>.+?) # and attributes instead braces
[[:blank:]\h]*
\}
[ \t]* # Possibly followed by spaces or tabs
\n # With then a new line
(?<!\\) # Making sure this is not escaped
(?<header_type>[\=|\-]+) # Multiple = or -
[ \t]* # Possibly followed by spaces or tabs
\n # Terminated by a new line
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
Header {#id1}
======
Header { #id2}
------
Header {.cl}
======
Header { .cl}
------
Header {.cl.class}
======
Header { .cl .class}
------
Header {#id5.cl.class}
======
Header { #id6 .cl .class}
------
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)