use strict;
my $str = 'Header {#id1}
======
Header { #id2}
------
Header {.cl}
======
Header { .cl}
------
Header {.cl.class}
======
Header { .cl .class}
------
Header {#id5.cl.class}
======
Header { #id6 .cl .class}
------
';
my $regex = qr/(?<header_all>
(?<header_content>.+) # Header content
[ \t]*
(?<!\\) # Making sure it is not escaped
\{
[[:blank:]\h]* # Possibly with some spaces
(?<header_attr>.+?) # and attributes instead braces
[[:blank:]\h]*
\}
[ \t]* # Possibly followed by spaces or tabs
\n # With then a new line
(?<!\\) # Making sure this is not escaped
(?<header_type>[\=|\-]+) # Multiple = or -
[ \t]* # Possibly followed by spaces or tabs
\n # Terminated by a new line
)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}