#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=(?:\s\"))[\s\S]+?(?=\")|(?<=(?:\s))\d+"
Local $sString = "oneParticularFunction({" & @CRLF & _
" key1: "string value"," & @CRLF & _
" key2: 12345," & @CRLF & _
" key3: "strings which may contain ({ arbitrary characters })"" & @CRLF & _
"});"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")