re = /(?<=(?:\s\"))[\s\S]+?(?=\")|(?<=(?:\s))\d+/
str = 'oneParticularFunction({
key1: "string value",
key2: 12345,
key3: "strings which may contain ({ arbitrary characters })"
});'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end