$re = '/(?<=(?:\s\"))[\s\S]+?(?=\")|(?<=(?:\s))\d+/';
$str = 'oneParticularFunction({
key1: "string value",
key2: 12345,
key3: "strings which may contain ({ arbitrary characters })"
});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);