using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:\s\""))[\s\S]+?(?=\"")|(?<=(?:\s))\d+";
string input = @"oneParticularFunction({
key1: ""string value"",
key2: 12345,
key3: ""strings which may contain ({ arbitrary characters })""
});";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}