import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?:\\s\\\"))[\\s\\S]+?(?=\\\")|(?<=(?:\\s))\\d+";
final String string = "oneParticularFunction({\n"
+ " key1: \"string value\",\n"
+ " key2: 12345,\n"
+ " key3: \"strings which may contain ({ arbitrary characters })\"\n"
+ "});";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}