#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(b|y)([0-9])+\/"
Local $sString = "? 143/200" & @CRLF & _
"a2/-1.6ppm 145/200" & @CRLF & _
"? 80/200" & @CRLF & _
"? 148/200" & @CRLF & _
"Int/AG/-1.2ppm,Int/GA/-1.2ppm 86/200" & @CRLF & _
"y16/-1.1ppm 180/200" & @CRLF & _
"y16+i/-1.0ppm 133/200" & @CRLF & _
"y17/-1.3ppm 170/200" & @CRLF & _
"y17+i/-1.8ppm 125/200" & @CRLF & _
"y18/-2.3ppm 116/200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")