use strict;
my $str = '? 143/200
a2/-1.6ppm 145/200
? 80/200
? 148/200
Int/AG/-1.2ppm,Int/GA/-1.2ppm 86/200
y16/-1.1ppm 180/200
y16+i/-1.0ppm 133/200
y17/-1.3ppm 170/200
y17+i/-1.8ppm 125/200
y18/-2.3ppm 116/200';
my $regex = qr/^(b|y)([0-9])+\//mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}