const regex = /^(b|y)([0-9])+\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(b|y)([0-9])+\\\/', 'gm')
const str = `? 143/200
a2/-1.6ppm 145/200
? 80/200
? 148/200
Int/AG/-1.2ppm,Int/GA/-1.2ppm 86/200
y16/-1.1ppm 180/200
y16+i/-1.0ppm 133/200
y17/-1.3ppm 170/200
y17+i/-1.8ppm 125/200
y18/-2.3ppm 116/200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}