# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(b|y)([0-9])+\/"
test_str = ("? 143/200\n"
"a2/-1.6ppm 145/200\n"
"? 80/200\n"
"? 148/200\n"
"Int/AG/-1.2ppm,Int/GA/-1.2ppm 86/200\n"
"y16/-1.1ppm 180/200\n"
"y16+i/-1.0ppm 133/200\n"
"y17/-1.3ppm 170/200\n"
"y17+i/-1.8ppm 125/200\n"
"y18/-2.3ppm 116/200")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.