$re = '/^(b|y)([0-9])+\//m';
$str = '? 143/200
a2/-1.6ppm 145/200
? 80/200
? 148/200
Int/AG/-1.2ppm,Int/GA/-1.2ppm 86/200
y16/-1.1ppm 180/200
y16+i/-1.0ppm 133/200
y17/-1.3ppm 170/200
y17+i/-1.8ppm 125/200
y18/-2.3ppm 116/200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);