import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ (?!To:|Subject:).*$\\r*\\n*";
final String string = " To: 1234@abc.com\n"
+ " From: 5678@abc.com\n"
+ " Message-info: hshjsjsjjsjdjdjsjjsj\n"
+ " Subject: email regarding\n"
+ " Your new house";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}