use strict;
my $str = ' To: 1234@abc.com
From: 5678@abc.com
Message-info: hshjsjsjjsjdjdjsjjsj
Subject: email regarding
Your new house';
my $regex = qr/^ (?!To:|Subject:).*$\r*\n*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";