import Foundation
let pattern = #"^ (?!To:|Subject:).*$\r*\n*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
To: 1234@abc.com
From: 5678@abc.com
Message-info: hshjsjsjjsjdjdjsjjsj
Subject: email regarding
Your new house
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)