re = /^ (?!To:|Subject:).*$\r*\n*/m
str = ' To: 1234@abc.com
From: 5678@abc.com
Message-info: hshjsjsjjsjdjdjsjjsj
Subject: email regarding
Your new house'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result