$re = '/^ (?!To:|Subject:).*$\r*\n*/m';
$str = ' To: 1234@abc.com
From: 5678@abc.com
Message-info: hshjsjsjjsjdjdjsjjsj
Subject: email regarding
Your new house';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;