# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?P<number>\d+) (?P<word>\w+)/\g<word> \g<number>/gm;t' <<< "ABC 123 Book 456
ZZZ 789 KKK XYZ"