#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?P<number>\d+) (?P<word>\w+)"
Local $sString = "ABC 123 Book 456 " & @CRLF & _
"ZZZ 789 KKK XYZ"
Local $sSubst = "\g<word> \g<number>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)