use strict;
my $str = 'ABC 123 Book 456
ZZZ 789 KKK XYZ';
my $regex = qr/(?P<number>\d+) (?P<word>\w+)/mp;
my $subst = '\\g<word> \\g<number>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";