$re = '/(?P<number>\d+) (?P<word>\w+)/m';
$str = 'ABC 123 Book 456
ZZZ 789 KKK XYZ';
$subst = "\g<word> \g<number>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;