re = /(?P<number>\d+) (?P<word>\w+)/m
str = 'ABC 123 Book 456
ZZZ 789 KKK XYZ'
subst = '\\g<word> \\g<number>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result