package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(>)()(<\/)`)
var str = ` <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<any_other_tag></any_other_tag>
<any_other_tag> </any_other_tag>
<segments>0000</segments>
</file>`
var substitution = "\1[!] value does not exist!\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}